Trainz Discussion Forum - Powered by Jointed Rail Productions, LLC.

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to TrainzForums!

Author Topic: Updating Trainz 2010  (Read 4543 times)

actionhank

  • Engineer
  • ***
  • Offline Offline
  • Posts: 135
Updating Trainz 2010
« on: January 23, 2011, 05:11:40 PM »

In an effort to get Ek3 working, i have been trying to update my version of Trainz 2010, hoping that it would resolve my issue, since finding all the assets, and reinstalling everything, then doing the content check through the content manager haven't seemed to work.
I just can't for the life of me figure out this update system for Trainz. I have tried google and Auran's website (Which not surprisingly was nothing short of useless...).
I have build 41491 according to my Trainz launch screen, but every update i have tried installing hasn't worked for me.
I'm not sure if maybe i just missed an update, or what, but if you guys could help me out i would appreciate it a lot.
I'm trying to get EK3 running since it looks amazing, but Trainz seems to have other plans.  :facepalm1:
Logged

gfisher

  • TrainzForums Moderator
  • Dispatcher
  • *****
  • Offline Offline
  • Posts: 1237
Re: Updating Trainz 2010
« Reply #1 on: January 28, 2011, 04:54:12 PM »

You need to go here: http://www.auran.com/servicepacks/#TS2009 where you can download the service packs. You need service pack 1, 41491 to 41615, service pack 2, 41615 to 42203, service pack 3, 42203 to 43434, and finally the Hotfix pack, service pack 43434 to 44088. Install them in order. Read the directions on the page about disabling your antivirus and internet connection first. The first three may take an hour or two to install depending on how much content you have installed and the speed of your computer. Just go have a cup of coffee and leave it alone. The last patch installed in five minutes for me.
Logged

"Beer is proof that God wants us to be happy." - Thomas Jefferson

actionhank

  • Engineer
  • ***
  • Offline Offline
  • Posts: 135
Re: Updating Trainz 2010
« Reply #2 on: January 30, 2011, 07:07:37 PM »

Thanks for the reply.
I meant to update that i found them all...but then the installer froze up midway through, and i guess it messed something up, because it wouldn't launch Trainz, and i couldn't get it to try repatching.
So i've uninstalled it, and i'm going to try and redownload it. (If i can find the link on Auran's website. That company is awful about handling their products...)
Logged
 

Page created in 0.061 seconds with 21 queries.